Tag Archives: WOLF

Using WADE in Eclipse using WOLF Plugin

WADE is a software platform based on JADE that provides support for the execution of tasks defined according to the workflow metaphor. The key component of the WADE platform is the WorkflowEngineAgent class that extends the basic Agent class of the JADE library embedding a small and lightweight workflow engine. Besides normal JADE behaviours, a WorkflowEngineAgent is therefore able to execute workflows represented according to a WADE specific formalism. This formalism is based on the Java language: a WADE workflow is actually a Java class with a well defined structure. This approach makes it possible to combine the expressiveness of the workflow metaphor with the power of a programming language such as Java, and enables the usage of workflows for system internal logics definition.

In principle WADE supports “notepad-programming” in the sense that there is no hidden stuff that developers can’t control. However, especially considering that one of the main advantages of the workflow approach is the possibility of representing processes in a friendly graphical form, WADE comes with a development environment called WOLF that facilitates the creation of WADE-based application. WOLF is an Eclipse plug-in and as a consequence allows WADE developers to exploit the full power of the Eclipse IDE plus additional WADE-specific features.

Go to the WADE Website to Download WADE & WOLF

To install WOLF in Eclipse…. download the zip files for the plugin to your local system.

You must register before you can download the files, if you already registered to download JADE you can use that account to login.

Extract the contents of the zip files into the Eclipse plugin directory where you installed Eclipse on your system. (Make sure to extract the actual plugin in the plugin folder of the zip file to the plugin folder inside of eclipse.) This needs to be done as a manual installation according to the instructions for installing WADE

Read Chapter 1.1: WADE Installation Tutorial or see below

WOLF
As mentioned WOLF is an Eclipse plugin and therefore it is necessary to have Eclipse version 3.3 (Europa) or later already installed. Actually versione 3.4 is suggested as it fixes some bugs that may create annoying problems when using WOLF. Furthermore WOLF makes use of the GEF (Graphical Editing Framework) plugin for graphic rendering version 3.3 or later that must be
installed too. Both Eclipse and GEF can be downloaded from the Eclipse website at http://www.eclipse.org.
At this point the easiest way to install WOLF is unzipping the WOLF distribution zip file (available for download from the WADE website at http://jade.tilab.com/wade) into the Eclipse home directory. Refer to the Eclipse documentation for more details about plugins installation.
If a previous version of WOLF is already installed, it is necessary to remove it from the Eclipse plugins directory (by simply deleting the subdirectory related to WOLF) before installing the new one. Both WADE and WOLF require Java 5 or later.

Additional  articles related to WADE:

Read about WADE: A software platform to develop mission critical applications exploiting agents and workflows

Read more about WADE and how it works